首页 > 游戏制作 > WordPress升级后报错wpdb::prepare()

WordPress升级后报错wpdb::prepare()

有时候我们升级WordPress版本后,会发现首页底部出现一串英文字符报错

出现的报错内容开头为:warning:Missing argument 2 for wpdb::prepare()

网上出现这个问题的人不在少数,似乎wordpress3.5,wordpress4.0各种都有出现

好久没写技术贴了,微知自己在网上仔细研究了下看看这个报错是什么问题

至于什么代码我们不用去管,因为那些意义不是很大,每个人都有不同

可能有人问为什么不同呢,因为我们都会在文件里面加入一些广告或搜索代码

所以我们看到的报错英文串码上的标识行数的数字都不一样,但是原理是一样的

比如底部出现错误,我们打开footer.php文件,找到这个:post_date_gmt > 1970″));

然后我们把它修改成:post_date_gmt > 1970″, “”));实际上就是加了, “”保存后就可以了

似乎各个不同的WP版本升级出现的问题都是相同的,你看错误在那个文件就改哪里好了

据说这是Wordpress更改安全算法做的调整,目地干掉不勤快更新的主题作者,囧

分类: 游戏制作 标签:
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.